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ORA Geospatial Features

• Geospatial visualization
– Basic features: 

• Zoom
• Pan
• Select

– Network analysis
• Color/Size by network properties
• Export geospatial network
• Smoothing measures over space

• Geospatial Trail Visualization
– View trail
– Change trail resolution
– Loom-OraGIS compatibility

• Geospatial network resolution 
changes
– Choose appropriate level of 

granularity/summarization
– Balance with information loss

• Geospatial Information Loss
• Network Information Loss
• Shapefile import and export
• KML export
• Key Locations Report
• GeoSpatial Assessment Report
• Create spatial nodesets
• Create spatial relations
• Save/Load view configuration
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Representing Geospatial 
Information

• Attributes
– Latitude/Longitude
– MGRS
– UTM

• Relations
– “is-located-at” relations
– John->Chicago means John is located at Chicago

• Working on easing the transition between named places 
and geographic coordinates
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Representing Geospatial 
Information – Two Defaults

• “Only Locations” default
– Only location nodes can have coordinate information
– Nodes that are connected to that location via a “node -> 

location” link are said to be in that location

• “Everything has a Location” default
– Any node can have coordinate information
– Links are just links. They don’t imply any special relationship 

beyond what they’re already meant to imply

• If your data lacks the geospatial attributes, you can specially 
configure your data to work with GIS. This is called “Hard Mode”
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The Previous Slide, Only as a Chart

5

Can coordinates be found?

Which 
nodesets have coordinates?

Yes

HARD 
MODE

No

Only location nodesets At least one non-location 
nodeset

Any networks with a TARGET to a 
location nodeset infer a “is located 

at” relationship.
Source Nodes get added to Target 

Location

No extrapolation. Everything gets 
placed where it’s coordinate says it 

should go.

DATA
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Representing Geospatial 
Information: Default A

• Nodes of type “Location” are checked for attributes
– “mgrs”
– “latitude” and “longitude”
– “utm”

• All networks to/from a node of type “Location” are 
“is-located-at” networks

• This method is handy when you’re working with more general 
locations that multiple entities can inhabit. It allows for a type of 
aggregation before the map is even opened.
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Representing Geospatial 
Information: Default B

• Multiple nodesets are checked for attributes
– “mgrs”
– “latitude” and “longitude”
– “utm”

• If only “Location” nodes are found, it defaults to the “old” default. If 
multiple nodesets are found, it uses the “new” default.

• This method tends to be preferred when you want each entity to 
have its own location. Data acquired directly from a GPS, for 
example.
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Representing Geospatial 
Information: Configuration, pt.1

• Using the “Add GIS Attribute” 
button, you can specify what 
to use for that Node Class’s 
coordinates

• This must be done for each 
node class you want to use 
as “locations”
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Representing Geospatial 
Information: Configuration, pt.2

• In the next window, you can 
specify the Networks to be 
used to establish “Who is at 
Where”.
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Three Different Visualizations
• 2-dimensional map (pretty)

– Powered by Jmap
– Pulls down map images from multiple sources
– Requires an internet connection
– Medium scalability

• 2-dimensional map (nice personality)
– Powered by Openmap
– Highly scalable
– Low computational requirements

• 3-dimensional map
– Powered by NASA’s WorldWind Java
– Less scalable
– Requires relatively modern graphics card and more memory
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Loading Data

• Load the network in the geospatial folder of your 
data disk (Flightpaths.Avenged.xml) into the 
GeoSpatial Networks visualizer
– Import the file into ORA
– Select Flightpaths
– Menu: Visualization  Geospatial Networks
– If your data matches the default convention (which this one 

will), you can also use the small down arrow on the “Visualize” 
button to open GIS

•
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What You’ll See
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Basic Navigation

• Select the   pan tool from the toolbar
– Left Click + Drag to pan around
– Mouse wheel forward to zoom in
– Mouse wheel backward to zoom out
– Or use the zoom bar on the map to zoom in/out
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Get/Set View

• Useful for creating screenshots 
of the same area using 
different datasets
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Rest of the Toolbar

• Toggle Labels on/off
• Toggle Links on/off
• Toggle Link Arrows on/off
• Change the Font Size
• Change the Minimum Node Size
• Change the Maximum Node Size
• Change the Link Width
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Node Size

• By increasing the Maximum 
node size, you can start to see 
more info about a location

• By default, Node Size 
corresponds to the number of 
nodes associated with that 
location
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Size Nodes by Attribute/Measure

• Using “Analyze Network”, you 
can size nodes by different 
Attributes or Measures

• In this screenshot, we resized 
by “Centrality Betweenness.”
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Size/Color by Network Measures

• Open the Size/Color dialog boxes
– Analyze Network → Size Nodes by Attribute or Measure
– Analyze Network → Color Nodes by Attribute or Measure

• Explore different network measures
– Color by Closeness centrality
– Color by Eigenvector centrality

• Explore groupings
– Analyze Network → Color By Newman Grouping
– Analyze Network → Color By CONCOR Grouping
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(Color by)
Centrality, Betweenness

Recenter or Zoom to update sizes
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(Color by)
Girvan-Newman Grouping
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Using the Layer Manager
• Meta-Network Layers

– Enable/Disable nodeset layers
– Enable/Disable network layers
– Clicking the Box/Line allows you to change 

colors

• Add ESRI Shapefile
• Spatial Layers

– Enable/Disable spatial layers
– Clicking the Box/Line allows you to change 

colors
– Change the order of the Layers
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Layer Manager (cont.)

• Choose Network Layers • Change Network Colors

After changing the color, recenter or 
zoom to refresh the map



CASOS

12

June 2020

Explore Network Aggregation

• Open the dialog:  Tools → Network Aggregator
– Move the slider back and forth to change the level of 

aggregation
– When you’re done experimenting, set it to .04

• Note:  Even without any set aggregation level, if two 
locations have the same Coordinates, they’ll still be 
aggregated together

• How does aggregation work? Density-Based Clustering!
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Export the network from ORA

• As an image: File → Save Map → Save Map To PNG
• As a shapefile: File → Save Map → Save Map To SHP
• As a Google Earth file: File → Save Map → Save Map To 

KML (Only in Commercial Versions of ORA)
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The Map Options Menu

• The map options menu is Map source dependant.
– In the pretty map version, it provides multiple map sources
– In the not-so-pretty map, it doesn’t do anything
– In 3d maps, it allows for flat earths and other tools
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Alternate Map Sources

• Under the Map Options menu, you can select the source 
for your maps. 

Bing Aerial Stamen Terrain Stamen Watercolor

OpenStreetMap
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Switching Between Maps

• Under “Options”, you can switch between the three 
different mapping programs.

• “Jmap” is what has been featured in every previous 
slide.

• “Openmap” will be seen in one slide, right after this 
one.

• “NASA Worldwind” will also be seen in an upcoming 
slide
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OpenMap (Just a screenshot)
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Use the 3D Visualization

• Options → Use 3D Visualization
• Zooming

– Scroll the mouse scroll wheel to zoom
– Or press CTRL-<up arrow> and CTRL-<down arrow>

• Warning: this requires a somewhat powerful 
computer, and is still very slow on large datasets
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Use the 3D Visualization
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An Introduction to Shapefiles

• Database for Geographical Data
• Contains a set of Polygons, Points, Lines, or Lists of 

Polygons
• Described using a set of coordinates
• Consist of more than one file

– .shp : geometry of the shapes
– .dbf : attributes of the shapes
– .shx : shape index

• Recommended resources
– http://www.census.gov/geo/www/tiger/shp.html
– http://maplibrary.org/
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Loading Shapefiles

• Load in the Shapefile using “Shapefiles -> Add… -> Add ESRI 
Shapefile”

• For this example, we’ll be using tl_2009_us_state.shp.  It contains 
shapes for all United States territories.

• ORA has three shapefiles included with it
– Countries of the world
– US States
– International Timezones

• Yes, I’m having you load in something that’s already available in 
ORA.
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The Shapefile, Loaded in
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Shapefile Based Operations

• Shapefiles -> Color by Node Count
• Shapefiles -> Color by Attribute Measure

• Shapefiles -> Color Shapes by Links…
– ->…by Internal Link Count
– ->…by External (Outgoing) Link Count
– ->…by External (Incoming and Outgoing) Link Count
– ->…by Internal/External Link Ratio
– ->…with No External Links
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Shapefile Base Operation

• Most Operations operate the same way.  Select the 
option, select the Coloring parameters, and the 
operation executes.

• A Location is considered inside the shape if a shape 
contains that location’s 
coordinates
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Color by Node Count
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Color by Internal Link Count
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Stuff to Watch Out For

• Border locations.  Portland is 
still in Oregan, which is good, 
but improper rounding or a 
faulty script could easily place 
it in washington
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Stuff to Watch Out For

• Centroids.  Oddly shaped areas 
can have centroids placed in 
another territory.  Croatia here 
is a fine example.

• Croatia really doesn’t want 
Bosnia to have access to the 
beach. Don’t be like Croatia.
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Using Shapefiles as a Source of 
Locations

• File -> Add GIS Data -> Import Locations from Shapefile

• This will use the shapefiles .dbf file to bring in a number of 
locations, usually one per shape, for use in ora.

• Using the same state shapefile we used before…
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Result
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Result cont.

• The meta-network has a new Location node class called 
“tl_2009_us_state locations”

• Each location has whatever attributes it had in the Shapefile’s .dbf.  
What exactly this entails varies from shapefile to shapefile.
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Example Report
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Geospatial Network Centrality

• ORA Key Entities->Where Report
– Key Locations by Centrality
– Key Locations by Agents
– Key Locations by Events
– Key Locations by Resources
– Key Locations by Exclusivity
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The Region Viewer

• The Region Viewer is very, very similar in form and 
function to GIS, but it puts far more emphasis on 
shapefiles.

• It uses many of the same shape/location algorithms as 
GIS, but is a bit more streamlined
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The Region Viewer
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• On startup it’ll ask for a shapefile. Give it one, and it’ll 
determine all the locations inside any given shape


