Visualizer Basics

Jon Storrick

Jon.Storrick@gmail.com

More Demo than Presentation

- This presentation will be a follow-along walkthrough of the Network Visualizer
- These slides are included more for reference than anything.
- As such there may be deviation from these slides as questions arise. At minimum, I will be going over everything present within.
**Agenda**

- Loading a Meta-Network into the Visualizer
- Visualizer, at a glance
- Selecting which Node Classes and Networks to display
- Creating Meta-Networks in the Visualizer
- Viewing Node and Link information
- Manipulating the Appearance of the Visualization
- A brief introduction to the Tools
- Saving the Visualization as an image or meta-network
- Other Visualizations

- This presentation will use the Marvel Phase 1 dataset. If you consider this content to be spoilers, I don’t care. It’s been ten years.

**Visualizing your Meta-Network, pt.1**

- Select a meta-network in the Meta-Network Manager (yellow), and then click the Visualize button (red)
Visualizing your Meta-Network, pt.1

- Alternatively, you could select the following menu item – it does the same thing (2-D Visualization)

The Visualizer

- You should then get a new application window that contains the entire meta-network
Layout

- By default, the visualizer uses a spring-embedded layout. This means nodes try to push each other apart, while links try to pull nodes closer.
  - As a caveat of this, link length contains no meaningful info
- While the run button (▶) is enabled, the layout is always on. If you grab a node, the entire meta-network will be drug along with it. To stop this, select the stop layout button (⏹).
- Alternatively, any nodes that are pinned (by right clicking a node), that node will cease to be able to be moved by the active layout.

Anatomy of the Visualizer

- The Toolbar (red)
- Zoom/Status (green)
- The Legend (blue)
- Mouse Tools (yellow)
The Toolbar

- Copies the Visualizer image to the Clipboard
- Starts the Layout
- Stops the Layout
- Auto-zooms the visualization
- Rotates the Visualization
- Toggles label rendering on/off
- Toggles link rendering on/off
- Toggles link arrow rendering on/off
- Sets the node labels’ font size
- Sets the node size
- Sets the link width
- Opens the Meta-Node dialog
- Toggles between the spot/small shape/large shape node styles
- Opens the Node Highlighter

Zoom/Status Bar

- On the bottom of the visualizer is the zoom and status bars.
- When zoom is selected, sliding the scrollbar will cause the visualization to zoom in and out
- When hyperbolic is selected, sliding the scrollbar causes the hyperbolic effect to increase
The Legend

- Using the visualizer’s legend, you can select which node classes and networks you want to display. Whenever a node class is toggled off, any networks that use that node class is also toggled off.
- By clicking on a node’s or link’s image in the legend, you can also change the color of all nodes and links in that node class or network.
- If your legend disappears, it can be found under the Tools menu as “Legend.”

The Legend, an Example

- By toggling off all but the Agent node class, we also hid any networks using the Location, Resource (Armaments), or Organization node classes.
Mouse Tools, pt. 1

- Pan Image. If you select this one and “grab” a node, you can then pull the node around. If you “grab” white space, the picture moves as a whole
- Box Select. Using this tool you can draw a box around a group of nodes. Once you release the mouse button, the surrounded nodes become selected
- Paint Tool. This is used to draw on the screen with a brush, and allows you to choose the thickness and color

- In most cases, you’ll want to stay in the Pan mouse mode. Most of the commands in this presentation operate under the assumption that you’re in the Pan mouse mode.

Mouse Tools, pt. 2

- We’ll go into these in more detail in a later presentation
- Node Creator – Using the Toolbar, you select the node class to create the nodes in, or to create a new node class.
  - To create a node, simply click on any white space
- Link Creator – The toolbar allows you to select which network to create the links in. By default, it will automatically find compatible networks to create links in, and create networks when no such networks exist.
  - To create a link, press the left mouse button on a node, and release on the target node
- Eraser – Used to either hide or completely delete nodes and links.
  - To use, either click a node/link, or drag over the nodes/links
By now, you've likely discovered the Node Status window. When the checkbox at the bottom of the window is selected, the dialog will appear any time a node is selected. To turn this off simply uncheck the checkbox.

In this dialog, you can view all known information about a node, from computed measure values to the nodes neighbors.

This dialog also offers the ability to edit the node. You can add attributes in the attribute tab and change the node title by changing the node title field's value.

This dialog can also be found through the Menu (Tools -> Node Status) or by double clicking a node.

URIs is a special tab. Here you can view all of the URIs associated with a node.

A URI is an attribute of type "URI" that corresponds to a location that can be accessed. This location can be on the web, on the hard disk, or on another type of media.

Each URI comes with it's own "Launch" button. Clicking that button will open up a browser window and take you to the location specified in the URI.

Much like with Attributes, URI's can be added right through the URI tab.
Viewing Information About a Node/Link

- Links have a status window of their own, found by double clicking on a link.
- It contains all the available information about the link, including weight, source node, target node, and any attributes/sources/URIs associated with the link.

Alternatively, hovering over a node/link brings up a tooltip full of information relevant to the node/link.
Manipulating the Visualization

- For any given node/link, there are dozens of ways we can change how they look. Color, shape, their labels, even if whether we want to show them or not.
- Generally speaking, the Actions menu deals with visibility, while Node or Link Appearance alters how the elements are rendered.

Key Action Options

- “Isolates -> Hide Isolate Nodes”. An isolate node is any node that lacks any connections to any other nodes.
- “Hide Pendant Nodes”. A pendant node is any node that has only one neighbor node.
- “Recursively Hide Pendant and Isolate Nodes”. Will constantly try to remove pendant and isolate nodes until no further nodes can be hidden.
- “Compute Standard Measures for Visible Network”. Computes a number of measures on the currently visible network. These measures can be seen in either a node’s tooltip or a node’s status window.
Measures in the Visualizer

- Measures aren’t just numbers we give to a node, you can also use them to manipulate the visualization. The most common one is “Size Nodes by Attribute or Measure”, found in “Node Appearance”.

Size Nodes by Attribute or Measure

- In the resulting dialog, you can select either an attribute or a measure to size by.
- The lower the measure/attribute value, the smaller the node will be.
- To cause the node sizing to take effect, click the “Apply Changes” button.
Size Nodes by Attribute or Measure

- Since we sized by Centrality, Betweenness, nodes on the outside are smaller, while the more central nodes are larger.

Handy Link Display Options

- "Link Appearance -> Show Multiple Links Between Nodes". As it is common for nodes to have more than one link between them, this allows you to see all those links.

- "Link Appearance -> Scale Link Width to Value". For non-binary networks, this allows you to see the actual weight of the links.

- "Link Appearance -> Link Color...". By default, the visualizer colors all nodes the same color as their source node. Here, you can change that color to either the default, by source, by target, or by link weight.
Node Images

- By default, all nodes are shaped according to the style and their nodetype. However, if you have the media, you can give your nodes their own images.
- Nodes can get their images from one of two places – a URI (if it’s on the web), or from a file.

Node Images - URI

- Here’s the Wikipedia address for an image of Iron Man.
  - https://upload.wikimedia.org/wikipedia/en/e/e0/Iron_Man_bleeding_edge.jpg
  - To give him this image in the visualizer, the first thing we must do is assign this image to him. In ORA’s main interface, create a new attribute “Image” of type “URI”.
- Find Tony Stark, and set that attribute’s value to the address listed above.
Node Images - URI

- From the Visualizer, select "Display -> Node Appearance -> Load Node Images". That will bring up a prompt asking for the attribute we should grab images from.

- Since the attribute was called "URI Image", select "URI Image", and click "Ok". Since the attribute was of type URI, it will go to the address specified and grab the image, and set the node to display that image.

Node Images – Manual Selection

- If you already have the images on your computer, you can also change a node's image another way.
- Download the Iron Man image linked earlier. It's location isn't terribly important, as long as you know where it is.
- Right click a node, and under appearance, select "Set Picture".
Node Images – Manual Selection

- This brings up a small Image Chooser. While ORA has a number of icons pre-installed, we’re currently interested in custom images. Select “custom” from the pull down box, and then click the “New Image” button. Find the image we just downloaded, and select it.

- That will bring the image into the image chooser. Select the icon, click “Ok”, and the image will be loaded into that node.

- This also does a few things in the backend.
  - First, it will give that node an attribute “image” and set it to the filename of the selected image. In this case, “ghailani.jpg”.
  - Second, it will give the meta-network an attribute called “image folder”. When you save the meta-network, it will create a new folder in the same directory as the meta-network, and transfer all we just loaded into that folder. Assuming it can write to that location, of course.
  - Then, whenever you want to revisit these images, all you need to do is use the “Load Node Images” prompt with the “image” attribute. The visualizer will find the images using the relative path, and load them just the same.
A Brief Introduction to Tools

- Under the Tools menu you’ll find a number of options to help you perform a number of different tasks. Some help you to perform tasks on only certain nodes/links, some are there to help you see information in a new way, while others help you show only the nodes you’re interested in.
- For now, we’ll focus on three of the tools – the Sphere of Influence, the Path Finder, and the Node Locator.

Sphere of Influence

- The Sphere of Influence tool allows you to see the ego net of a selected group of node(s). When used, it shows only the nodes/links in the ego net.
- Should multiple nodes be selected, it shows the union of those nodes’ ego nets.
- You have control over which node classes you want included in the ego net, how many degrees away from the ego nodes you want, and which nodes should act as the ego nodes.
- This dialog always acts off of the true meta-network, unless the “use only visible…” option is selected.
Sphere of Influence, an example

- Looking at all nodes within one degree of Obediah Stane
- Note: In the resulting network, the selected nodes are given a ring

Path Finder

- The path finder, as its name implies, finds all paths starting from one node and ending at another.
- By default, it ignores both link direction and link weight. To enable them toggle the corresponding option on in the options panel.
- In “Advanced Options” you can specify a third node, and force it to either include it/exclude it/avoid it as much as possible.
- When paths are found, the shortest path length is displayed at the bottom of the dialog (in terms of link count).
Path Finder, an example

- Looking at all paths from S.H.E.I.L.D. to the Ten Rings

Node Locator

- For dense/large population networks, it can sometimes be hard to find a particular node of interest. The Node Locator is designed to help with that.
- To find a node, either traverse the tree to the proper letter or node class and select it. The search bar will create a new subtree containing all nodes containing the input search substring.
- Once a node is selected, a small animation plays as the visualizer pans over to the selected node. Once it's done, the selected node will be in the exact center of the visualizer.
- Nodes in the exact center will not move when zooming in/out.
**Bonus Node Location Method – the Node Highlighter**

- As seen on the toolbar, the Node Highlighter allows you to find a node by typing in its name.
- When the button is clicked, a small text field appears. When you type in the field, it searches all node titles for the input substring, and displays a list below it.
- Selecting a node will cause a ring to be drawn around it.

---

**When You’re Done...**

- When you’re done creating an image in the visualizer, it is often useful to save it, either as an image to a file, or back into the main interface.
- To save as an image, use the following menu item:
  - “File -> Save Image to File”
- To save the currently visible meta-network back into the main interface, use the following menu item:
  - “File -> Add Meta-Network to ORA”
  - This will create a new meta-network in ORA’s meta-network manager containing only the visible links and nodes.